I suggest you ...

Add a "resend" option to MMS or texts in general.

MightyText in the browser still just displays a clock "waiting for phone to send message" and the phone just won't send - so its stuck. We need some option to trigger a "re-send to phone" or text update or something!

343 votes
Vote
Sign in
(thinking…)
Password icon
Signed in as (Sign out)
You have left! (?) (thinking…)
glennpotter shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

22 comments

Sign in
(thinking…)
Password icon
Signed in as (Sign out)
Submitting...
  • smitro88 commented  ·   ·  Flag as inappropriate

    Anybody out there listening. Waiting for you to answer question, or solve problem

  • Martino Vallachi commented  ·   ·  Flag as inappropriate

    Same here. Message sending/receiving is not reliable--at least not in any timely manner. Also, I seem to be able to receive pictures, but sending pics from my Android phone doesn't always work. I think I'll be better off using a free web-based SMS program that isn't linked to my phone. (These have always worked well for me.)

  • Tophy commented  ·   ·  Flag as inappropriate

    100% agree. I've been using MightyText for a while, and while I love the concept and utility, I hate the app. It's incredibly unreliable. I'd estimate that maybe 50% of my messages send at best right away. The rest just sit there for minutes to hours before sending -- if they ever do.

    I'd love to have an app with 1/10th the features that actually worked.

  • andrew.mcegan71 commented  ·   ·  Flag as inappropriate

    I also have the same problem, but there seems to be no action from MightyText. The focus seems to be on the improvement with the paid Pro version, so I expect there would be very little support
    or investigation into this. I also expect this message to be "Pending" without a satisfactory resolution from MightyText.

  • lauren.andyj commented  ·   ·  Flag as inappropriate

    I came here just to give the same suggestion. It's already annoying to have to go through all the steps (unlink, turn off, etc. ) to attempt to send the message again (I say attempt because that doesn't always work and I usually just cave and end up sending from my phone). I don't want to also have to re-type the message or forward the message. Allow me to hit resend and try again. It even says "try again" in the whole "make sure your phone is on" message- but you really can't unless you completely recreate the message...

  • jameswendellmiller commented  ·   ·  Flag as inappropriate

    Unlinked phone and relinked - seems to be working now but still a bit troublesome. The pic is only 110kb and the phone is on wifi so I don't see why its not working.

  • frause commented  ·   ·  Flag as inappropriate

    same thing happening here....i can send group MMS on my phone but the web app won't do it.

  • pariccifr commented  ·   ·  Flag as inappropriate

    Same ....MightyText in the browser still just displays a clock "waiting for phone to send message" and the phone just won't send - so its stuck.

    Can you fix it or explain how it can works . MERCI

  • dorte.mai commented  ·   ·  Flag as inappropriate

    Seems to be serious problem - for me too. Will try to reinstall - but hopefully only once?

  • Lisa Merchant commented  ·   ·  Flag as inappropriate

    This happens quite often. I try to refresh that does not help. Some times I have uninstall the app and re install for the app to work again. It has become very bothers some.

  • Anonymous commented  ·   ·  Flag as inappropriate

    Same problem here. Has checked all Mightytexts help information, nothing fixes this issue. The MMS are just pending with a clock-icon on the computer, but the phone never sends the picture/MMS. Just infinite pending. SMS sends ok, but the app isn't much worth, if it can't send MMS :(

  • dom2114 commented  ·   ·  Flag as inappropriate

    ive had the same issue to. i find the best fix is to unlink and relink the mightytext app on the phone. as soon as its relinked, it works perfectly. not sure what causes the problem in the first place though and would love a fix.

← Previous 1

Feedback and Knowledge Base